Announcement

Collapse
No announcement yet.

Sudden loss of power HELP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sudden loss of power HELP

    Hi I'm Tricia, new to the ur site. Desperately seeking help. I have a 2009 CDTi. And yesterday morning I got in it to go to work and found myself struggling to get it down the road. There's no power. When I rev it, it hits no more than 3000rpm. Won't go faster than 80kph and I takes forever to get to 60. A friend plugged diagnostics in tonight and its showing a 8 codes, p0676, p2453, p2459, p003a, p2459, p0101, p053a, p0113. Any idea if any of these would cause the issue. Never had problem with car. So I'm at a loss

  • #2
    Hello Tricia we are a fun and friendly forum
    if you could make your way to new members section and introduce yourself to us
    just a couple of lines about you and your car
    and this lot like pictures
    heres a useful link
    https://insignia-drivers.uk/forum/we...-introductions





    10-4 new member !


    .K.M.P.C.U
    YEEEEEEEEHAAAAAAAAA

    Comment


    • #3
      Originally posted by Pstrogen View Post
      Hi I'm Tricia, new to the ur site. Desperately seeking help. I have a 2009 CDTi. And yesterday morning I got in it to go to work and found myself struggling to get it down the road. There's no power. When I rev it, it hits no more than 3000rpm. Won't go faster than 80kph and I takes forever to get to 60. A friend plugged diagnostics in tonight and its showing a 8 codes, p0676, p2453, p2459, p003a, p2459, p0101, p053a, p0113. Any idea if any of these would cause the issue. Never had problem with car. So I'm at a loss
      Sounds like it's gone into limp mode. Could be a clogged dpf
      2011 2.0 cdti ecoflex excnav
      honeycomb grill, squinty eyes, custom lettering, honeycomb custom fog grills, custom lower centre grill, full black back tints, chrome door knobs, rear wiper removed, custom back badge, custom DRLs, custom diffuser, custom wing, stage 1 remap, pipercross air kit, 210bhp 440nm torque, more on the way

      Comment


      • #4
        Your first code is wrong
        Because it's telling me that cylinder number 6 has a faulty glow plug.
        You also have a code for faulty exhaust gas temperature sensor.
        And a code for differential pressure sensor outside tolorences .
        And a code for Air intake temperature outside range .
        A code for MAF sensor outside tolorences.
        I would first lean towards Blocked DPF
        Because the MAF and AIT and gas exhaust temperature codes tell me that the exhaust gases have no where to escape ie what comes in must go out.
        If there's no where to go then it's going to throw everything else out of Kilter.
        Sorry I can't be of much help at moment but I'm in bed need my beauty sleep.
        But do you know of someone with a good diagnostic tool like opcom ?
        You may be able to get it to force regeneration.
        But first clean MAF .MAP . throttle body.checj oil level ( if above max and smells of Diesel then change oil and filter toot sweet before anything else.
        Not promising anything with the forced regen .
        Depending on the saturation level but to me it seems very ill .




        10-5 plastic bag!

        Sent from my Nokia 7.1 using Tapatalk



        .K.M.P.C.U
        YEEEEEEEEHAAAAAAAAA

        Comment


        • #5
          Hello
          codes
          P0676 = cylinder 6 glowplug circuit ( you don't have a 6 cylinder diesel

          P2453 = fuel filter pressure sensor out of range ,could be blocked or dirty filter or wiring issue ,i.e. Short circuit damaged wiring

          P2459 = DPF regeneration Frequency not conforming to parameters i.e. Regeneration has either been halted or interrupted ,or not being performed correctly


          P003A= turbocharger boost control circuit A outside range ,i.e.Vaines in the turbo are stuck or boost control soliniod is not working or damaged wiring or split in vacuum lines ,


          P0101 +Mass airflow outside range ,i.e. Dirty or clogged air filter , mass airflow sensor dirty or damaged or problems with air intake pressure too high .


          P0530 + Air conditioning pressure switch signal too high or too low ( dose your air conditioning work ?)



          P0113 + intake air temperature circuit too high ,i.e. The temperature of the comming air ( fresh air ) cannot be calculated



          most of thease ( bar number 1 ) throw the EML on and cause loss of power

          is the car well serviced ?
          is the car used on short trips ?
          whats the mileage ?





          10-4 rubber duck


          .K.M.P.C.U
          YEEEEEEEEHAAAAAAAAA

          Comment

          Working...
          X