Announcement

Collapse
No announcement yet.

The Comprehensive Haldex thread

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The Comprehensive Haldex thread

    Noticed that this seems to be a sticking point with the Insignia, I was quoted 3500 by VX to repair mine some months ago....
    I refused and started investigations, shortly after it was fixed and at a cost of under 200 including labour.

    Anyway I have a PDF file that is a full Bible of info on diagnostics and repairs... And enabled me to identify and repair mine.
    How would I go about sharing that on here as a PDF?
    And the below info that will be helpful for those in need.

    German site for replacing the haldex oil.

    https://www.insignia-freunde.de/inde...el-neue-infos/

    Haldex service kit (seal and filter)

    https://www.bristoltransmissionsshop...e-kit-14-p.asp

    Haldex full service kit (seal, filter and oil)

    https://www.ebay.co.uk/itm/173872678566

    Haldex Service kit (seal, filter)

    https://www.haldexparts.com/20986573...th-gasket.html

    Haldex oil Gen 4

    https://www.haldexparts.com/4th-gen-...2-for-awd.html

    Pump repair kit

    https://www.ebay.com/itm/323450948663

    Replacement Gen 4 pump (not direct fit, plug will need to be cut off and spliced on to extend wiring)

    https://www.haldexrepairs.co.uk/shop...mp-haldex-vag/

    Replacement Gen 4 pump (direct fit plug and play)
    Part No: 0404029 22765779


    https://www.haldexparts.com/opel-saa...l-pump-gm.html

    Bulletin from Vauxhall

    Technical Service Bulletin 2942

    Subject: Differential gear - Service rear axle message displayed, DTCs C0403 or C0407 set
    Brand: Model: Model Year: VIN: Engine: Transmission: from | to from | to Opel, Vauxhall Insignia 2011 2012 B1148800 C1083244 A20DTH,A20DTR,A20NFT,A20NHT,A28NER,A28NET All
    Option All Wheel Drive Complaint Customer notices that "Service Rear Axle" is displayed in driver information display. Cause Rear Differential Module (RDM) electronic Limited-Slip Differential (eLSD) clutch piston seal may leak causing mixed oil in one chamber while the 2nd chamber from the Torque Transfer Device (TTD) runs dry. Insufficient dimensional accuracy of seal ring. DTC 0407(64) set. Production

    Remedy

    In case of customer complaint the eLSD clutch piston seal has to
    be replaced.

    Haldex Part 2

    Field Remedy: 2660

    Subject: Driver Information Center - Service Rear Axle message displayed, DTC C0403 stored
    Models: Engines: Option: Insignia 2009...2010 All AWD (All Wheel Drive)
    Complaint: Service Rear Axle message displayed in the Driver Information Center DTC C0403 symptom code 62 stored in the Rear Differential Clutch Control Module. Cause: DTC may be set due to tolerance deviation of the internal differntial clutch oil filter. Production: Improved parts have been introduced in production as of VIN: W0LGX6EGA1127041 (08 July 2010).

    Remedy:

    In case of customer complaint replace differential clutch oil filter
    and reprogram the Rear Differential Clutch Control Module.

    Additional external links to Haldex repairs site (best around and a great guy that will provide info and support)

    https://www.haldexrepairs.co.uk/repl...er-andor-pump/

    https://www.haldexrepairs.co.uk

  • #2
    Haldex Repair info from GM
    Attached Files

    Comment


    • #3
      Nice one Nick... bedtime reading now

      Comment


      • #4
        Good bit of info there, glad it mentions filling the unit via the vent hose hole as when I first done this I filled via the check hole and had an error come up. Followed a guide but it gave the wrong filling procedure

        Sent from my J8110 using Tapatalk

        Comment


        • #5
          Originally posted by Iceman205 View Post
          Good bit of info there, glad it mentions filling the unit via the vent hose hole as when I first done this I filled via the check hole and had an error come up. Followed a guide but it gave the wrong filling procedure

          Sent from my J8110 using Tapatalk
          I gave up trying to fill it via the vent and just pumped it in the bottom until it came out the top.

          The first time I tried it I didn't put enough oil in to overcome the internal gate so had an error.
          The second time I just filled it till it came out the top and let it drain back out through the bottom.
          Was spot on then.

          Comment


          • #6
            Heads up guys, just fixed the broken links.
            Should all be working again now.
            ​​​​

            Comment


            • #7
              Such a superb detailed write up.....I've made this a sticky

              Comment

              Working...
              X