Announcement

Collapse
No announcement yet.

Strange power loss issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange power loss issue

    Hi all could use some help/guidance what to look for.
    I have an insignia cdti from 2010, 160ps model.
    Lately had a strange issue sometimes.
    Usually happens when going round corners or up/down.
    It is like someone hits a brake for a split second and then it goes away.
    You can feel a jerk and then it continues normally.
    Car otherwise works normally, engine is smooth, pulls good.
    Does not smoke at all. I can press the throttle and virtually no black smoke at all.
    Car has done 120 000 miles roughly.
    No error codes according to cheap bluetooth scanner
    What should I check (Egr/dpf/turbo pipe/injectors)
    any recommendations are welcome.
    Would like to know if anyone had something similar
    Any advice is appreciated

  • #2
    Check your cheap scanner and get a good one .
    but a couple of questions
    1) do you regularly clean the egr or map or map sensors?
    2) is it regularly serviced?
    These kind of things can become a case of parts roulette.
    but I would be inclined to get a diagnostic tool that has live data functionality on it .







    34t-456666 black jack !


    .K.M.P.C.U
    YEEEEEEEEHAAAAAAAAA

    Comment


    • #3
      A little update.
      Tried to take egr off, could not budge it out.
      Cleaned the pipe next to egr, thre was some crap inside but not much.
      Replaced the air filter cause it was dirty but not horrible.
      Also put dpf cleaner and took it for a blast for half an hour.
      Car goes like a rocket but that stupid problem is still there. Went to a roundabout and felt it again.
      I can try the map sensor clean and the throttle body but dont think it will make any difference

      Comment


      • #4
        Originally posted by MathewSt View Post
        A little update.
        Tried to take egr off, could not budge it out.
        Cleaned the pipe next to egr, thre was some crap inside but not much.
        Replaced the air filter cause it was dirty but not horrible.
        Also put dpf cleaner and took it for a blast for half an hour.
        Car goes like a rocket but that stupid problem is still there. Went to a roundabout and felt it again.
        I can try the map sensor clean and the throttle body but dont think it will make any difference
        Could it be some air in the fuel line somewhere? Like lizzard-t says running some live data might help. You might see a fuel pressure drop or something.

        Comment


        • #5
          I can try to get some live data with that cheap bluetooth odb2 interface and a car scanner app on the phone. So to check fuel rail pressure live data right?

          Comment


          • #6
            Hello, as Drew says ,fuel rail pressure, and fuel trims ,if your scanner will do live data then it will probably do the whole lot as one log rather than individual.
            it could be a case of a dirty fuel filter, as from your description it seems to happen on corners or as you explain it, when going up and down,
            .


            .K.M.P.C.U
            YEEEEEEEEHAAAAAAAAA

            Comment


            • #7
              Ok so will try to see if I can get some live data logged and post it here.
              Ive been reading a lot about this online so couple of thing I found or would like to ask if they can be maybe the issue.
              First thing is steering pump that maybe is giving trouble??
              The second thing is maybe cv joint.
              Any thoughts on these two

              Comment


              • #8
                I doubt it,you would hear/feel a cv joint and most likely the steering pump would scream or you would have steering issues.The best bet would be a good reader to see if you have fault codes stored.
                Insignia Elite 16T,Royal Blue non Nav. + added,
                Heko Wind Deflectors,Alloy Pedal Covers.Led full Interior,Polished Alloy Door Pins,Osram Diadem Opel Rear indicator Bulbs,Led Reverse Light Upgrade,Gear Surround Red Leds,Led reg plate lights,Nighteye Fog lamp Bulbs,Osram Night Breaker Laser Cornering Bulbs,Rear Sunblinds,Nextbase 522GW front/rear window cam,upgraded front speakers,SS Exhaust,6000k Xenon Bulbs,Thinkdiag Diagnostic Tool

                Comment


                • #9
                  A quick update,
                  Still did not do live data but did quite a few things to the car. Changed all filters, rechecked the codes (none stored), Replaced and cleaned brakes completely (new discs, pads allround and lubed everything) so brakes are ok.
                  Issue is still present, most noticeable when the engine is cold.
                  Happened this morning, I mean a sudden burp/hesitation then continued to drive.
                  There are no strange noises at all from the engine.
                  I wander could it somehow be that the car needs a software update

                  Comment


                  • #10
                    Sounds similar to what i had on my bmw. The problem was the EGR, full of cr@p. I would start with cleaning the EGR and go from there.

                    Comment


                    • #11
                      I am thinking more and more that this is dmf related. There is a small change in sound/noise when pressing/depressing clutch pedal it seems.
                      Also when this happens car seems to become more bouncy somehow, ride feels choppier at lower speeds.
                      Al of this is not noticeable at highway speeds, there car drives fine you cannot notice anything.

                      Comment


                      • #12
                        A little more update or clarification. Went for a 600 mile drive yesterday, and issue happened a few times.
                        Most pronounced is when changing from 1 to 2 gear you can feel it. Yesterday once if was struggling three or four times when I changed from to 2. Once it happened when changing from 3 to 4th gear.
                        Otherwise car works normally, put some premium fuel and liquy molly diesel additive. Engine works like a charm.
                        Regarding previous post for dmf maybe I was wrong, There is a small difference with pressing/depressing the clutch but there is that failsafe for not able to rev the car that engages dissengages
                        Can this be some sort of fuel pressure sensor or fuel pressure regulator problem maybe or even ecu remap maybe that is needed??
                        Will take the car to dealer to see if they can see some codes that I cannot or have any idea about this.

                        Comment


                        • #13
                          The fuel pressure sensor is on the end of the fuel rail right hand side.
                          now with you saying it seems worse from cold we did have a few on here with similar problems
                          And one was the fuel pressure sensor.sensor But to save money its best to take it to a good garage because they have the correct diagnostic equipment.


                          .K.M.P.C.U
                          YEEEEEEEEHAAAAAAAAA

                          Comment


                          • #14
                            Thanks lizzard.
                            I know where the fuel pressure sensor is, although I have no idea where the regulator is. :-(

                            Comment


                            • #15
                              the regulator is on the back of the high pressure fuel pump ..
                              if the pressure sensor is not reading the correct pressure it will try to compensate by shutting down the fuel regulator if too high
                              or open it up if too low .thus giving a higher or lower fuel delivery. Which will cause symptoms of the car trying to break wind !


                              .K.M.P.C.U
                              YEEEEEEEEHAAAAAAAAA

                              Comment

                              Working...
                              X