Follow us on...
Follow us on Facebook Follow us on instagram
Register

User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6
  1. #1
    Learner Driver Mike.brickles's Avatar
    Join Date
    Oct 2017
    Posts
    39
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Help rough idle 2.0 CDTI

    Forum Key Rings
    Hi

    been looking on on the net about rough idle on insignia there seems to be a few videos of people rev gauge moving up down at idle, mine seems like its about to stall when the rev drops

    seems to be a problem with fuel pressure regulator sensor located at the back of engine.

    been looking at replacement about 109 from eurocarparts

    anyone had this problem and has replacing the fuel pressure regulator sensor sorted it ?

    Here is a couple of videos people have post which what im getting. https://www.youtube.com/results?sear...nia+rough+idle

    has anyone changed fuel pressure regulator on here if so is it easy enuff to do ?

  2. #2
    Learner Driver Paul47's Avatar
    Join Date
    Sep 2018
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you replace the fuel pressure regulator? I have the same problem!

  3. #3
    Learner Driver Harry kellett's Avatar
    Join Date
    Sep 2018
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi did you bleed the fuel system of air after changing the proportional pressure regulature?

  4. #4
    Learner Driver Flasheris's Avatar
    Join Date
    Sep 2016
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I did change it. It was an easy job, three bolts undo and pull it out, just do not forget to refit the gasket from old part (it might be stuck to sensor or the pump it self - guess how I know ).
    No bleeding needed, system is automatically bled. And it for sure helped with the bouncing idle issue.

  5. #5
    Learner Driver Harry kellett's Avatar
    Join Date
    Sep 2018
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    So changed the fuel pressure regulature and idle rpm has stabilised. The engine still sounds like it is struggling to run. It tries to stall under load at low rpm. I'm woundsring if this is airflow problem or cylinder pressure problem. I'm going to try changing mass airflow sensor and use some edge cleaner. Anyone got any ideas

  6. #6
    Learner Driver Paul47's Avatar
    Join Date
    Sep 2018
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi, did you sort out your rough idle? Thanks

 

 

Similar Threads

  1. 2009 2.0 CDTI EcoFlex - rough idle on cold start
    By blade954 in forum Engine, Drive Train & Transmission
    Replies: 19
    Last Post: 16-04-2019, 08:31 AM
  2. 2009 2.0 CDTI EcoFlex - rough idle on cold start
    By blade954 in forum General Chat
    Replies: 2
    Last Post: 16-06-2018, 11:09 AM
  3. Rough starting .
    By ssc100 in forum Engine, Drive Train & Transmission
    Replies: 1
    Last Post: 14-11-2016, 11:14 AM
  4. Car running rough
    By Auto.de in forum Engine, Drive Train & Transmission
    Replies: 1
    Last Post: 11-01-2015, 12:53 PM
  5. idle control valve? 2.0 cdti sri 160
    By DeaniFLHT in forum Engine, Drive Train & Transmission
    Replies: 0
    Last Post: 05-05-2014, 11:48 AM

Tags for this Thread

Posting Permissions