Follow us on...
Follow us on Facebook Follow us on instagram
Register

User Tag List

Thanks Thanks:  2
Likes Likes:  1
Results 1 to 8 of 8

Thread: Loss of power

  1. #1
    Learner Driver Dan45's Avatar
    Join Date
    Jul 2019
    Posts
    4
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Loss of power

    Forum Key Rings
    Can anybody help with my intermitent problem thanks for help in advance

  2. #2
    Learner Driver Dan45's Avatar
    Join Date
    Jul 2019
    Posts
    4
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Need help my insignia loses power intermitent any ideas would be brill

  3. #3
    Speed Demon 0011728's Avatar
    Join Date
    Apr 2011
    Location
    Manchester
    Car
    2ltr Elite Turbo Hatch Manual with all the toys and more
    Posts
    2,121
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Well lets see..................we don't know if its petrol or diesel, error codes, whether it happens under heavy load or normal acceleration. Do you think we are mind readers? A bit more information may help.................just a little
    Insignia Elite Nav 2ltr SIDI Turbo 250PS, Pearlescent Emerald Green, VX-Line Interior, VX-Line Exterior Styling Kit, Premium Brandy Nappa Sports Leather, 20" Elite Multi Spoke Alloy Wheels, 8" Digital Drivers Display, Bose Premium Audio System, Front Camera Pack, Rear View Camera, Adaptive Cruise Control, Advanced Park Assist, Rear Privacy Glass, Keyless Entry & Start, Tyre Pressure Monitoring System, Factory Fitted Towbar

  4. Likes exclusiv. liked
  5. #4
    Learner Driver Dan45's Avatar
    Join Date
    Jul 2019
    Posts
    4
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Sorry its 1.8 petrol it happens either load and not alway under acceleration no error codes either

  6. #5
    New Driver kentishbloke's Avatar
    Join Date
    Jun 2015
    Location
    Sittingbourne, Kent
    Car
    Insignia Elite 1.8, Pomegranate, standard apart from Sino Smart V2 unit, LED interior bulbs & K&N.
    Posts
    186
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Are you running the car with the aircon on all the time? This is a bad thing to do with the 1.8, it reduces the power significantly!

    The next thing to do is get a decent code reader plugged in & scan for stored codes. Unfortunately some cheaper ones don't do a full scan or can't pick up the stored codes properly.

    Having a 1.8 petrol myself, I've had some performance issues, aside from it being underpowered anyway. The 1st thing I had was a coil pack issue not long after I bought it, but that threw up a misfire code & went into limp mode & was sorted by a new coil pack under warranty.

    Next I had a knocking noise from the top left of the engine, which was solved by replacing the cam solenoids, this then showed I had a lack of power before I reached them, I thought it was just because its an underpowered engine for the weight of car.

    Lastly, I replaced the spark plugs & this has transformed the performance! Whereas before I couldn't accelerate in 6th up a long hill on the M2 in Kent, now it sails up there & accelerates all the way up without changing gear!

  7. Thanks Dan45 Thanked
  8. #6
    Learner Driver Dan45's Avatar
    Join Date
    Jul 2019
    Posts
    4
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    sometimes when it happens the rev counter stops working and when you accelerate there is a ticking noise

  9. #7
    Member of Marko's black wheels Club PeteH's Avatar
    Join Date
    May 2019
    Location
    West Yorkshire
    Car
    1.5T SRi Nav GS, lava red, bi-colour alloys, full leather, reversing camera and lots of toys!
    Posts
    677
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Dan45 View Post
    when you accelerate there is a ticking noise
    That'll be the crocodile
    2018 1.5T SRi Nav in Lava Red with bi-colour alloys, full heated leather, reversing cam with park assist, heated front screen and steering wheel, blind spot monitoring, self parking (used once, it's crap!)

  10. #8
    The Stig

    sriray's Avatar
    Join Date
    Jul 2014
    Location
    Nottingham
    Car
    Insignia SRi NAV 1.6T Hatchback
    Posts
    6,377
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    @Dan45
    Please watch your language we are a friendly site on here. We do not tolerate this sort of behaviour.

    OWNER OF 2012 INSIGNIA SRI NAV HATCHBACK 1.6T

  11. Thanks PeteH Thanked
 

 

Similar Threads

  1. Loss of power when cold
    By Buckoab in forum General Chat
    Replies: 0
    Last Post: 28-10-2017, 11:28 AM
  2. Loss Of Power When Driving....
    By 0011728 in forum General Chat
    Replies: 5
    Last Post: 03-12-2015, 12:47 PM
  3. loss of power
    By cholly69 in forum General Chat
    Replies: 8
    Last Post: 20-10-2015, 06:27 AM
  4. Intermittant loss of power
    By Auto.de in forum Engine, Drive Train & Transmission
    Replies: 11
    Last Post: 22-09-2015, 08:59 AM
  5. Loss of power
    By Logosgil in forum General Chat
    Replies: 1
    Last Post: 26-05-2015, 05:25 PM

Tags for this Thread

Posting Permissions