Follow us on...
Follow us on Facebook Follow us on instagram
Register

User Tag List

Thanks Thanks:  4
Likes Likes:  2
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    New Driver robbo137's Avatar
    Join Date
    Jun 2019
    Location
    stockport
    Car
    cdti 2.0 elite auto white
    Posts
    78
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    bulb blown instrument panel 2012 elite

    Forum Key Rings
    Is it an easy job or shall i leave it ,temp pod dial is intermittent thanks in advance

  2. #2
    Member of Marko's black wheels Club RBH's Avatar
    Join Date
    Feb 2018
    Location
    U.K
    Car
    2014 VX LINE
    Posts
    3,567
    Post Thanks / Like
    Mentioned
    32 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by robbo137 View Post
    Is it an easy job or shall i leave it ,temp pod dial is intermittent thanks in advance
    The instruments are lit by smds, not bulbs. Unusual for an OEM one to go.

  3. Thanks robbo137 Thanked
  4. #3
    The Stig

    sriray's Avatar
    Join Date
    Jul 2014
    Location
    Nottingham
    Car
    Insignia SRi NAV 1.6T Hatchback
    Posts
    6,377
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Mine is like that atm but the top left of the fuel gauge, some nights it lights up and some nights not. Is this the smd on way out or circuitry issue

    OWNER OF 2012 INSIGNIA SRI NAV HATCHBACK 1.6T

  5. Thanks robbo137 Thanked
  6. #4
    Member of Marko's black wheels Club RBH's Avatar
    Join Date
    Feb 2018
    Location
    U.K
    Car
    2014 VX LINE
    Posts
    3,567
    Post Thanks / Like
    Mentioned
    32 Post(s)
    Tagged
    1 Thread(s)
    It's usually caused by dry solder joints.
    Throughout the years, solder dries and cracks causing failure then it dies.
    I had this with a few times with the Vectra C's.
    It had to be removed and reflowed.

  7. Thanks robbo137 Thanked
  8. #5
    Speed Demon Mo_miah's Avatar
    Join Date
    Oct 2013
    Location
    Northampton
    Car
    2.0cdti se ecoflex hatchback 2011
    Posts
    2,436
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Good time to get Karl to work his magic

  9. Thanks robbo137 Thanked
  10. #6
    The Stig

    sriray's Avatar
    Join Date
    Jul 2014
    Location
    Nottingham
    Car
    Insignia SRi NAV 1.6T Hatchback
    Posts
    6,377
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by RBH View Post
    It's usually caused by dry solder joints.
    Throughout the years, solder dries and cracks causing failure then it dies.
    I had this with a few times with the Vectra C's.
    It had to be removed and reflowed.
    Cheers Rob. I thought that might be the case but wasn't sure hence said circuitry issue.
    I never had this issue on the vec c, but i did have the speedo cut out and it no longer moves, someone mention change the fuse should sort it, which i changed and it did sort it.

    OWNER OF 2012 INSIGNIA SRI NAV HATCHBACK 1.6T

  11. Likes RBH liked
  12. #7
    Advanced Driver Unilateral's Avatar
    Join Date
    Aug 2013
    Posts
    1,166
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    It’s nothing to do with dry joints generally. It’s the actual leds that are cheap crap. The solder has been done to perfection as you’ll see if you open them up. Simple enough job to desolder the old and resolder the new but you’ll need to do the whole lot in the dials pod to get them matching properly.

    Takes an hour if you know what your doing.

  13. #8
    The Stig

    sriray's Avatar
    Join Date
    Jul 2014
    Location
    Nottingham
    Car
    Insignia SRi NAV 1.6T Hatchback
    Posts
    6,377
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Unilateral View Post
    It’s nothing to do with dry joints generally. It’s the actual leds that are cheap crap. The solder has been done to perfection as you’ll see if you open them up. Simple enough job to desolder the old and resolder the new but you’ll need to do the whole lot in the dials pod to get them matching properly.

    OWNER OF 2012 INSIGNIA SRI NAV HATCHBACK 1.6T

  14. #9
    The Stig

    sriray's Avatar
    Join Date
    Jul 2014
    Location
    Nottingham
    Car
    Insignia SRi NAV 1.6T Hatchback
    Posts
    6,377
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Unilateral View Post
    Takes an hour if you know what your doing.
    So how long would it take you Karl

    OWNER OF 2012 INSIGNIA SRI NAV HATCHBACK 1.6T

  15. #10
    Street Racer umfaan's Avatar
    Join Date
    May 2014
    Posts
    271
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Like he said ....an hour as he knows what he is doing ....

 

 
Page 1 of 2 1 2 LastLast

Similar Threads

  1. Changing instrument Panel From small LCD to large LCD insignia 2016
    By m_arazik in forum Electronics & In Car Entertainment
    Replies: 17
    Last Post: 18-10-2018, 10:00 PM
  2. Insignia Estate 2.0 2012 Elite
    By PaulG69 in forum New Member Introductions
    Replies: 6
    Last Post: 02-09-2018, 01:49 PM
  3. Door handle chrome strip missing - 2012 Insignia Elite.
    By Bulleteer in forum Exterior Design
    Replies: 8
    Last Post: 04-06-2018, 05:11 PM
  4. Insignia Elite 09 driver information panel
    By Davell in forum Electronics & In Car Entertainment
    Replies: 0
    Last Post: 25-05-2013, 08:13 AM

Tags for this Thread

Posting Permissions