Follow us on...
Follow us on Facebook Follow us on instagram
Register

User Tag List

Thanks Thanks:  0
Likes Likes:  1
Loves Loves:  0
Results 1 to 5 of 5
  1. #1
    Learner Driver JamieD's Avatar
    Join Date
    Aug 2019
    Location
    Greenock
    Car
    2016 Sri Nav Hatch
    Posts
    24
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Heater control delay

    Forum Key Rings
    Does anyone else’s insignia have a delay on the heater controls? I usually leave my car with the air direction facing the window and on myself, but have noticed that when the car is first started there is a delay of a varying amount of time for the vents to change direction especially onto the windscreen position. Also the fan took a while to actually come on tonight, the blower setting was on 3 and it took around 2 minutes for the fan to actually start moving any air. Any you guys have the same or have solved this? Car is a 16 plate Sri

  2. #2
    Street Racer Drew's Avatar
    Join Date
    Dec 2019
    Location
    Sedgefield
    Car
    Insignia B ST SRI VXline 2.0d 170PS Auto Cosmic Grey
    Posts
    210
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think that's normal. My insignia A 2013 MY Sri nav did it. And my Insignia B does it. I think because everything is computer controlled these days it does it in order of importance, the same as when you switch on the lap top. Mine sorted heating etc before it will turn the radio on. If you stay in the car a few minutes after switching off you hear all the vents go back to their static positions. Used to unnerve my wife if she was sat in the car when it did it!

  3. Likes Dave1419 liked
  4. #3
    Car Enthusiast lizzard-t's Avatar
    Join Date
    Dec 2018
    Location
    Littlehampton West Sussex
    Car
    saab 9-3 turboX.9-3 1.9 TID,vectra B GSI,nissan qashqai.
    Posts
    966
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    If you have it on auto setting it could be waiting till there is enough coolant temperature to satisfy the demand .
    All my cars with AAC do that .the fan don't start till the coolant temperature is at a pre determined value .
    Try putting it on manual too see if that helps .

  5. #4
    New sheriff in town - Mind where you post or I'll have you!
    RBH's Avatar
    Join Date
    Feb 2018
    Location
    CENTRAL SCOTLAND
    Car
    VX LINE
    Posts
    4,430
    Post Thanks / Like
    Mentioned
    48 Post(s)
    Tagged
    1 Thread(s)
    It shouldn't take 2 minutes for the fan to kick in.

  6. #5
    Learner Driver JamieD's Avatar
    Join Date
    Aug 2019
    Location
    Greenock
    Car
    2016 Sri Nav Hatch
    Posts
    24
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    All the settings are set to manual, maybe the fan motor is on its way out? Will keep a eye on it this week and see how it goes.

 

 

Similar Threads

  1. Heater Control
    By Jasper in forum Wanted
    Replies: 5
    Last Post: 20-10-2018, 06:51 PM
  2. Driver window glass control- works with keyfob/ doesn't work with control switches
    By ncarthic in forum Electronics & In Car Entertainment
    Replies: 4
    Last Post: 14-07-2018, 10:31 PM
  3. Sorry for the delay. Damage update.
    By sriray in forum General Chat
    Replies: 0
    Last Post: 01-06-2015, 01:33 PM
  4. Power Delay
    By del19_82 in forum Engine, Drive Train & Transmission
    Replies: 4
    Last Post: 06-01-2015, 05:02 PM

Tags for this Thread

Posting Permissions